# Error after upgrading 14.7.13

**URL:** <https://community.bloomreach.com/t/error-after-upgrading-14-7-13/3703>\
**Category:** Experience Manager (PaaS/OnPrem)\
**Created:** [March 8, 2023, 12:25pm UTC](https://community.bloomreach.com/t/error-after-upgrading-14-7-13/3703 "2023-03-08T12:25:01Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![katmandu25](https://yyz1.discourse-cdn.com/flex027/user_avatar/community.bloomreach.com/katmandu25/32/1485_2.png) [@katmandu25](https://community.bloomreach.com/u/katmandu25)\
**Post date:** [March 8, 2023, 12:25pm UTC](https://community.bloomreach.com/t/error-after-upgrading-14-7-13/3703/1 "2023-03-08T12:25:02Z")

</div>

☹ i all.

After upgrading 14.7.13 and solving some sonar issues our application doesn´t start

It shows this error while starting CMS application

```auto
08.03.2023 12:36:51 ERROR main [RepositoryServlet.init:249] Error while setting up JCR repository: 
javax.jcr.RepositoryException: unchecked exception: java.lang.IllegalStateException: Module core/hippo-cms/hippo-services-htmlprocessor/hippo-services-htmlprocessor already exists while merging projects. Merging of modules is not supported.
	at org.hippoecm.repository.HippoRepositoryFactory.getHippoRepository(HippoRepositoryFactory.java:161) ~[hippo-repository-connector-14.7.13.jar:14.7.13]
	at org.hippoecm.repository.RepositoryServlet.init(RepositoryServlet.java:207) [hippo-repository-servlets-14.7.13.jar:14.7.13]
	at org.apache.catalina.core.StandardWrapper.initServlet(StandardWrapper.java:1134) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1089) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:983) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4902) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5211) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:717) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:690) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:706) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1093) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1810) [catalina.jar:9.0.43.redhat-00011]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_352]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_352]
	at org.apache.tomcat.util.threads.InlineExecutorService.execute(InlineExecutorService.java:75) [tomcat-util.jar:9.0.43.redhat-00011]
	at java.util.concurrent.AbstractExecutorService.submit(AbstractExecutorService.java:112) [?:1.8.0_352]
	at org.apache.catalina.startup.HostConfig.deployDirectories(HostConfig.java:1013) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:428) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1520) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:309) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:123) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.util.LifecycleBase.setStateInternal(LifecycleBase.java:423) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.util.LifecycleBase.setState(LifecycleBase.java:366) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:936) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.core.StandardHost.startInternal(StandardHost.java:843) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1384) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1374) [catalina.jar:9.0.43.redhat-00011]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_352]
	at org.apache.tomcat.util.threads.InlineExecutorService.execute(InlineExecutorService.java:75) [tomcat-util.jar:9.0.43.redhat-00011]
	at java.util.concurrent.AbstractExecutorService.submit(AbstractExecutorService.java:134) [?:1.8.0_352]
	at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:909) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.core.StandardEngine.startInternal(StandardEngine.java:262) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.core.StandardService.startInternal(StandardService.java:434) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.core.StandardServer.startInternal(StandardServer.java:930) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183) [catalina.jar:9.0.43.redhat-00011]
	at org.apache.catalina.startup.Catalina.start(Catalina.java:772) [catalina.jar:9.0.43.redhat-00011]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_352]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_352]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_352]
	at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_352]
	at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:342) [bootstrap.jar:9.0.43.redhat-00011]
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:473) [bootstrap.jar:9.0.43.redhat-00011]

```

And this one starting SITE application

```auto
08-Mar-2023 12:37:04.804 SEVERE [main] org.apache.catalina.util.LifecycleBase.handleSubClassException Failed to start component [Connector[AJP/1.3-8009]]
	org.apache.catalina.LifecycleException: Protocol handler start failed
		at org.apache.catalina.connector.Connector.startInternal(Connector.java:1074)
		at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183)
		at org.apache.catalina.core.StandardService.startInternal(StandardService.java:451)
		at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183)
		at org.apache.catalina.core.StandardServer.startInternal(StandardServer.java:930)
		at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183)
		at org.apache.catalina.startup.Catalina.start(Catalina.java:772)
		at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
		at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
		at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
		at java.lang.reflect.Method.invoke(Method.java:498)
		at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:342)
		at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:473)
	Caused by: java.lang.IllegalArgumentException: The AJP Connector is configured with secretRequired="true" but the secret attribute is either null or "". This combination is not valid.
		at org.apache.coyote.ajp.AbstractAjpProtocol.start(AbstractAjpProtocol.java:270)
		at org.apache.catalina.connector.Connector.startInternal(Connector.java:1071)
		... 12 more
08-Mar-2023 12:37:04.806 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in [585402] milliseconds
08.03.2023 12:37:05 ERROR http-nio-8080-exec-5 [HstFilter.doFilter:47] The HST Container Services are not initialized yet.
08.03.2023 12:37:05 ERROR http-nio-8080-exec-15 [HstFilter.doFilter:47] The HST Container Services are not initialized yet.
08.03.2023 12:37:05 ERROR http-nio-8080-exec-16 [HstFilter.doFilter:47] The HST Container Services are not initialized yet.
08.03.2023 12:37:05 ERROR http-nio-8080-exec-14 [HstFilter.doFilter:47] The HST Container Services are not initialized yet.

```

Can anybody help me please??? I think I have broken something ☹

---

<div class="post-metadata">

**Author:** ![jasper.floor](https://yyz1.discourse-cdn.com/flex027/user_avatar/community.bloomreach.com/jasper.floor/32/28_2.png) [@jasper.floor](https://community.bloomreach.com/u/jasper.floor)\
**Post date:** [March 8, 2023, 1:44pm UTC](https://community.bloomreach.com/t/error-after-upgrading-14-7-13/3703/2 "2023-03-08T13:44:21Z")

</div>

The first thing I would check for is if you have the right jars deployed to your shared libs. I suspect you may have multiple versions of the same lib deployed.

---

<div class="post-metadata">

**Author:** ![katmandu25](https://yyz1.discourse-cdn.com/flex027/user_avatar/community.bloomreach.com/katmandu25/32/1485_2.png) [@katmandu25](https://community.bloomreach.com/u/katmandu25)\
**Post date:** [March 8, 2023, 3:51pm UTC](https://community.bloomreach.com/t/error-after-upgrading-14-7-13/3703/3 "2023-03-08T15:51:49Z")

</div>

Hi jasper

Thank you for your answer,

I only change

```auto
 <parent>
    <groupId>com.onehippo.cms7</groupId>
    <artifactId>hippo-cms7-enterprise-release</artifactId>
    <version>14.7.13</version>
  </parent>

```

in my general pom.

After this, mvn clean install and deploy in our server. I looked for another version and i didn´t find anything. All jars in my Maven dependencies are 14.7.13

---

<div class="post-metadata">

**Author:** ![katmandu25](https://yyz1.discourse-cdn.com/flex027/user_avatar/community.bloomreach.com/katmandu25/32/1485_2.png) [@katmandu25](https://community.bloomreach.com/u/katmandu25)\
**Post date:** [March 9, 2023, 7:17am UTC](https://community.bloomreach.com/t/error-after-upgrading-14-7-13/3703/4 "2023-03-09T07:17:56Z")

</div>

Finally redeploy the project and works. No idea what happened. We are deploying in a Docker, so is very strange that another version persits.

Anyway thank you for your answer. @jasper.floor

There is another other that persists in the start up

```auto
08-Mar-2023 21:23:03.806 SEVERE [main] org.apache.catalina.util.LifecycleBase.handleSubClassException Failed to start component [Connector[AJP/1.3-8009]]
	org.apache.catalina.LifecycleException: Protocol handler start failed
		at org.apache.catalina.connector.Connector.startInternal(Connector.java:1074)
		at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183)
		at org.apache.catalina.core.StandardService.startInternal(StandardService.java:451)
		at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183)
		at org.apache.catalina.core.StandardServer.startInternal(StandardServer.java:930)
		at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183)
		at org.apache.catalina.startup.Catalina.start(Catalina.java:772)
		at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
		at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
		at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
		at java.lang.reflect.Method.invoke(Method.java:498)
		at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:342)
		at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:473)
	Caused by: java.lang.IllegalArgumentException: The AJP Connector is configured with secretRequired="true" but the secret attribute is either null or "". This combination is not valid.
		at org.apache.coyote.ajp.AbstractAjpProtocol.start(AbstractAjpProtocol.java:270)
		at org.apache.catalina.connector.Connector.startInternal(Connector.java:1071)
		... 12 more
08-Mar-2023 21:23:03.811 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in [662191] milliseconds

```

This is the log output, but the application seems to work properly

I have read that this error is produced for a vulnerability issue with AJP, but really I don´t know if the AJP is necessary of I can deactivate it in site application

Any idea that what could do?

---

<div class="post-metadata">

**Author:** ![jeroen.hoffman](https://yyz1.discourse-cdn.com/flex027/user_avatar/community.bloomreach.com/jeroen.hoffman/32/43_2.png) [@jeroen.hoffman](https://community.bloomreach.com/u/jeroen.hoffman)\
**Post date:** [March 9, 2023, 7:46am UTC](https://community.bloomreach.com/t/error-after-upgrading-14-7-13/3703/5 "2023-03-09T07:46:36Z")

</div>

Hi,  
The “configured with secretRequired=“true”” error seems to unrelated to the application but to how you’ve configured Tomcat in server.xml.  
If secretRequired=“true”, you must have a “secret” as well, see [Apache Tomcat 9 Configuration Reference (9.0.73) - The AJP Connector](https://tomcat.apache.org/tomcat-9.0-doc/config/ajp.html)

HTH  
Jeroen

---

<div class="post-metadata">

**Author:** ![jasper.floor](https://yyz1.discourse-cdn.com/flex027/user_avatar/community.bloomreach.com/jasper.floor/32/28_2.png) [@jasper.floor](https://community.bloomreach.com/u/jasper.floor)\
**Post date:** [March 9, 2023, 8:41am UTC](https://community.bloomreach.com/t/error-after-upgrading-14-7-13/3703/6 "2023-03-09T08:41:57Z")

</div>

HI,

sometimes errors disappear for no reason. I do believe the error you saw is related to multiple jars, but that shouldn’t happen in a docker container that you rebuild as necessary. I guess this was a Heisenbug. Jeroen has answered your other question, I have nothing to add to that.

---

<div class="post-metadata">

**Author:** ![katmandu25](https://yyz1.discourse-cdn.com/flex027/user_avatar/community.bloomreach.com/katmandu25/32/1485_2.png) [@katmandu25](https://community.bloomreach.com/u/katmandu25)\
**Post date:** [March 9, 2023, 10:33am UTC](https://community.bloomreach.com/t/error-after-upgrading-14-7-13/3703/7 "2023-03-09T10:33:32Z")

</div>

Thank you very much both of you. @jasper.floor and @jeroen.hoffman
