ERROR: Node already exists at path

#1

Hi guys, can someone help me? Got a following error: Processing ‘APPEND’ action for content node ‘/hst:hst/hst:configurations/mainsite-ru/hst:workspace/hst:containers/homepage/main/page-submenu’ failed. Node already exists at path /hst:hst/hst:configurations/mainsite-ru/hst:workspace/hst:containers/homepage/main/page-submenu.

What’s wrong? )))

09.04.2019 15:07:46 ERROR localhost-startStop-1 [ConfigurationContentService.apply:174] Processing ‘APPEND’ action for content node ‘/hst:hst/hst:configurations/mainsite-ru/hst:workspace/hst:containers/homepage/main/page-submenu’ failed.
javax.jcr.ItemExistsException: Node already exists at path /hst:hst/hst:configurations/mainsite-ru/hst:workspace/hst:containers/homepage/main/page-submenu
at org.onehippo.cm.engine.JcrContentProcessor.validateAppendAction(JcrContentProcessor.java:110) ~[hippo-repository-engine-5.1.2.jar:5.1.2]
at org.onehippo.cm.engine.JcrContentProcessor.apply(JcrContentProcessor.java:135) ~[hippo-repository-engine-5.1.2.jar:5.1.2]

#2

Hi,

it seems you haven’t gotten a response on this. The error implies you are adding something that already exists. Could you share your yaml?

#3

Hi, thnx for response. Sorry, but which yaml do you need? ))

#4

whichever one is loading or changing the node at

/hst:hst/hst:configurations/mainsite-ru/hst:workspace/hst:containers/homepage/main/page-submenu

#5

Hmmm, there’s no files with page-submenu name… page-submenu is only inside other configs, for instance: configuration.yaml or test-contentpage.yaml, etc.

#6

I’ve recently seen a similar issue. In that case it was related to a case error in the names used in the files. I think both the file name and the name in the order before did not match the node name.