# Issues after upgrading to v13

**URL:** <https://community.bloomreach.com/t/issues-after-upgrading-to-v13/932>\
**Category:** Experience Manager (PaaS/OnPrem)\
**Created:** [April 3, 2019, 11:40am UTC](https://community.bloomreach.com/t/issues-after-upgrading-to-v13/932 "2019-04-03T11:40:13Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Rahul\_Raj](https://yyz1.discourse-cdn.com/flex027/user_avatar/community.bloomreach.com/rahul_raj/32/329_2.png) [@Rahul\_Raj](https://community.bloomreach.com/u/Rahul_Raj)\
**Post date:** [April 3, 2019, 11:40am UTC](https://community.bloomreach.com/t/issues-after-upgrading-to-v13/932/1 "2019-04-03T11:40:13Z")

</div>

Hi All,

I am facing two issues after upgrading to v13 from 12.6.0.

1. No channels are visible. I have checked same issue mentioned at [1]. I have checked all the suggestion given there. Also i do not see any error in logs.I am trying this on my local machine.

2. Site is not accessible. It gives 404. I am getting following errors:

WARN main [AbstractApplicationContext.refresh:554] Exception encountered during context initialization - cancelling refresh attempt: org.springframework.beans.factory.BeanCreationException: Error creating bean with name ‘defaultCrispResourceCache’ defined in URL [jar:file:/C:/Workspace/Code/bloomreachexperience/target/tomcat9x/webapps/site/WEB-INF/lib/hippo-addon-crisp-core-2.1.0.jar!/META-INF/spring-assembly/addon/crisp/crisp-addon-cache.xml]: Cannot create inner bean ‘abstractCrispResourceEhCache$child#673e1cdb’ of type [org.springframework.cache.ehcache.EhCacheFactoryBean] while setting constructor argument; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name ‘abstractCrispResourceEhCache$child#673e1cdb’ defined in URL [jar:file:/C:/Workspace/Code/bloomreachexperience/target/tomcat9x/webapps/site/WEB-INF/lib/hippo-addon-crisp-core-2.1.0.jar!/META-INF/spring-assembly/addon/crisp/crisp-addon-cache.xml]: Error setting property values; nested exception is org.springframework.beans.NotWritablePropertyException: Invalid property ‘statisticsEnabled’ of bean class [org.springframework.cache.ehcache.EhCacheFactoryBean]: Bean property ‘statisticsEnabled’ is not writable or has an invalid setter method. Does the parameter type of the setter match the return type of the getter?  
[INFO] [talledLocalContainer] 05:48:21 ERROR main [SpringComponentManager.initialize:161] Failed to initialize invalid module instance, {org.onehippo.cms7.crisp.hst}, which will be just closed and ignored.  
[INFO] [talledLocalContainer] org.springframework.beans.factory.BeanCreationException: Error creating bean with name ‘defaultCrispResourceCache’ defined in URL

Also i see below:

SEVERE [main] org.apache.catalina.core.StandardContext.startInternal One or more listeners failed to start. Full details will be found in the appropriate container log file  
[INFO] [talledLocalContainer] 05:48:25.185 SEVERE [main] org.apache.catalina.core.StandardContext.startInternal Context [/site] startup failed due to previous errors

Please help what is causing these issue?

Thanks  
Rahul

[1] [brXM 13 - after Upgrade there are no channels visible](https://community.bloomreach.com/t/brxm-13-after-upgrade-there-are-no-channels-visible/878)

---

<div class="post-metadata">

**Author:** ![machak](https://yyz1.discourse-cdn.com/flex027/user_avatar/community.bloomreach.com/machak/32/1298_2.png) [@machak](https://community.bloomreach.com/u/machak)\
**Post date:** [April 3, 2019, 12:30pm UTC](https://community.bloomreach.com/t/issues-after-upgrading-to-v13/932/2 "2019-04-03T12:30:45Z")

</div>

CRISP version you have (2.1.0) is not v13 compatible, see:

> **[Release Notes - BloomReach Experience - Open Source CMS](https://documentation.bloomreach.com/library/concepts/crisp-api/release-notes.html)**
>
> Open Source Enterprise Content Management

---

<div class="post-metadata">

**Author:** ![Rahul\_Raj](https://yyz1.discourse-cdn.com/flex027/user_avatar/community.bloomreach.com/rahul_raj/32/329_2.png) [@Rahul\_Raj](https://community.bloomreach.com/u/Rahul_Raj)\
**Post date:** [April 3, 2019, 2:02pm UTC](https://community.bloomreach.com/t/issues-after-upgrading-to-v13/932/3 "2019-04-03T14:02:39Z")

</div>

Hi Machak,

It’s is coming as part if hippo-addon-personalization-dependencies and i am using version 1.1.0. Can you suggest how can i make it get the compatible version.

Also, how can i fix channel manager issue?

Thanks  
Rahul

---

<div class="post-metadata">

**Author:** ![Rahul\_Raj](https://yyz1.discourse-cdn.com/flex027/user_avatar/community.bloomreach.com/rahul_raj/32/329_2.png) [@Rahul\_Raj](https://community.bloomreach.com/u/Rahul_Raj)\
**Post date:** [April 4, 2019, 7:56am UTC](https://community.bloomreach.com/t/issues-after-upgrading-to-v13/932/4 "2019-04-04T07:56:31Z")

</div>

I am able to get rid of error related to crisp. site application gets deployed successfully too. However I still get 404 error. It says “The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.”.

Also ever since i have fixed the crisp issue i am getting “javax.jcr.RepositoryException: javax.jcr.RepositoryException: The session pool of the pooling repository has not been initialized or closed.” CMS and console is accessible though.

Thanks  
Rahul
