Reports Tab: charts are not displaying

We are using Bloomreach version 12.6 and the reports tab does show tables with info but none of the charts are displayed. In the documentation it mentions that flash has to be enabled but I’m not getting the usual warning I normally get when something using flash is going to b displayed.

The result is the following:

Would you know if I’m missing anything?

I have double checked the facet configuration and it seems right (I am getting results for tables with content in reports like My Documents or Team Documents but none of the charts show up.

Thanks for any advice or tip!

Hello Pedro,

In my browser (Chrome) I have Flash Blocked(default) setting enabled and I am not getting the warning either. Once I change the setting to Allow then I get the warning “Plug-in blocked”. From there I click “Run Flash this time” but I am still not getting the charts. After logging out and back in I can see the charts.

Could you try out using the same settings and flow?

Thanks and regards,

Hello Lef,

Thanks for your reply.

I tried that and no luck :frowning:

To double check that flash was enabled I tried the following site:

I get a notification there asking me to enable flash which I don’t get in hippo. I’m going to triple check if I’m missing anything about flash not being enabled for any possible reason but the chrome setting I have it set as “Ask first”, the only option available I had apart from the blocking option.

Can I be missing any dependency?

This is I think, the place where the chart should render in the My Documents report:

Is there any file I could look for that could be missing?

Hello Pedro,

the required dependencies are mentioned here. You can check also against an archetype and compare the facet nodes as well. But I doubt that you are missing one of the dependencies cause you wouldn’t be able to see any results in such case.

Example requests that you can look for if everything loads correctly:

The first one [1] should be loaded even if you block Flash. The second one [2] will load only once Flash is enabled.

HTH and regards,


Thanks again for your response. The weird thing is that I get access to both files when I open the report page, for example My Documents. But they are not loaded or rendered on the page. I wonder if there is somewhere where the call should be made to the flash file and it’s not being done.

Is there any way to debug that?