Add functionality for CMS end users to reset their own password

#1

Hello World,

I am trying to add reset password functionality in my CMS for which I followed this documentation https://bloomreach-forge.github.io/reset-password/, to test this I set up Fake SMTP server to see if I get reset password email and it worked in my local PFA

But when I deployed it in my test server it says my password has expired and didn’t allow me to login (couldn’t check logs either) hence forcing me to revert back all my changes.
This is the error which I am getting in my test server when I clicked on forgot password link PFA


I checked with my Infra team and they confirmed that SMTP server exists there for emails, not sure what is going wrong has anyone have integrated this functionality with there CMS? if yes could you guide me what is going wrong?

Thank you in advance for your help.
Regards
V Ritesh

1 Like
#2

Hey Ritesh,
It’s a problem that you can’t see the log files, those would probably be most helpful
Do you have any other ways to get those logs?

Also, did you follow all steps in the documentation? Are there any (related) configuration files on the server that you don’t provide during deployment or use a different one than you use locally?

#3

Hi Joost,
Thanks for your reply.
Me and Ritesh are in same team.
We could find log entries(while we hit reset password button) after reverting changes. Please find attachments

.
We have followed all the steps that mentioned in the documentation.
In test environment there is a different SMTP server configured than our local and it is confirmed by our infra team.

Thanks & Regards
Savan Raiyani

#4

first message clearly indicates it cannot find configuration document at:

/content/document/resetpassword/reset-password/reset-password path.

#5

Hi Machak,

It is able to find a path in our local and working as expected(please see the first post by VRitesh) but not working when we deployed it in test environment.
Thanks for your reply.

Thanks & Regards
Savan Raiyani

#6

Hi Joost,
Thank you for your reply.
Please find logs from our Test environment posted by Savan, as you can see it’s not able to find the path for value list document in Test environment at “/content/document/resetpassword/reset-password/reset-password” but the document does exist there and is able to find it in my local, not sure why it couldn’t at Test environment!
We followed all the steps mentioned in the documentation, all the server level configuration are managed by Bloomreach and they confirmed that everything is right not sure what is going wrong.

#7

Hi Machak,
Thank you for your reply.
Yes but the document do exist at the very mentioned path and is able to detect when I run this in my local, not sure why it couldn’t in my server.