Error upgrading from version 12 to 14

Hello all,

I have a Version 12 project that I’m upgrading to Version 14. Now I am getting the following error when I start the application .


[main] ERROR - Failed to apply config
javax.jcr.RepositoryException: The following node type change contains non-trivial changes.Up until now only trivial changes are supported. (see javadoc for org.apache.jackrabbit.spi.commons.nodetype.NodeTypeDefDiff):
        org.apache.jackrabbit.spi.commons.nodetype.NodeTypeDefDiff$ChildNodeDefDiff[itemName={}content, type=NONE, operation=NONE],
        org.apache.jackrabbit.spi.commons.nodetype.NodeTypeDefDiff$ChildNodeDefDiff[itemName={}baseline, type=NONE, operation=NONE],
        org.apache.jackrabbit.spi.commons.nodetype.NodeTypeDefDiff$ChildNodeDefDiff[itemName={}lock, type=MAJOR, operation=REMOVED],
        org.apache.jackrabbit.spi.commons.nodetype.NodeTypeDefDiff$ChildNodeDefDiff[itemName={}webbundles, type=NONE, operation=NONE]
    at org.apache.jackrabbit.core.nodetype.NodeTypeRegistry.checkForConflictingContent( ~[jackrabbit-core-2.20.2-h1.jar:2.20.2-h1]

Does anyone have an idea about what the cause is and how I can fix it?


You should upgrade one major version at a time, i.e. 12->13->14, did you do that?

Hi Saimir
yes I did, I started to have this error when I jumped from v13.4.4 to 14

What do you have in your current v13 on your [hcm:hcm] namespace? You can find it from the console, using the cnd export and then choosing hcm.

Hi Diego,
few things: always upgrade to the latest release version ( 13.4.9 in your case for example).
During major (and rarely some minor upgrades) rolling upgrade is not supported. You need to stop/restart all cluster nodes while upgrading.
Releases reference:

hi guys, I solved this issue cleaning the jackrabbit’s file system, thanks for your replies

Hi @dquiroz !

I’m running into the same error you did. Could you provide some more details on how you were able to clean the jackrabbit file system? I’ve searched through BR’s documentation, and I haven’t found any steps on how I can accomplish this.


Hi @sshearer,
most probably, it is following: delete old repository directory and re-indexed the server. Location of the directory depends on your tomcat deployment settings/script (flag is called repo.path e.g. “-Drepo.path=/some/path”), see:

“Repository Storage Directory Location” section on following page:

Thanks, @machak. This makes sense for cleaning the repo locally. How can I do this in an upper environment, where I deploy the distribution file? Should I just delete the repo folder before creating the distribution? Or do you know if this has to do with the sql server we created for our remote environment?

It is very similar process: you stop all your servers and empty those repository directories.
After that, you start your servers again and indexing process starts.
This is what we call “full re-indexing”.
Depending on the size of your project (number of assets, documents and images), this process can take some time to finish, anything between 15 min, up to hours for larger projects (if you have 100.000 or more documents/assets)

Thank you @machak. We will give this a try!

Hi Sarah

Basically I followed the process described by @machak

Thank you both! Reindexing helped to solve our problem. I appreciate the help.