Link renders to "pagenotfound"

I am new to Experience Manager.
I added Simple Content via Essentials. I am using the predefined Freemarker Templates.
The articles in the contentlist are rendered correctly- but the links point to “pagenotfound”.
I allso tried to access the detailpage directly by entering the Url into the browser. That also does not work.

Any hints?

Hi Thomas,
As far as I know, this works out of the box. There should be a site map item hst:myproject/hst:configurations/myproject/hst:sitemap/content/_any_.html that maps to your content, e.g. to /content/documents/myproject/content/sample-document

The link rewriting (the reverse of site map item matching, see [1]) should find it.



Are you just using default content? Are the linked documents published? Does it work in the channel manager view? Did you make any changes yourself?

Just ootb if you only used Essentials and made no changes then this should just work as @jeroen.hoffman says.

Thanks for your response @jasper.floor and @jeroen.hoffman !

It seems that through playing around something was broken :frowning:
I created a fresh project and it worked out of the box.:grinning:

Retuning to my old project I took the relevant documents offline and published them again in a new folder.

Now the links are rendered correct!

But now I have a new issue:
I pointed to the hst:relativecontentpath= content in the sitemapitem, Documents of annother folder are rendered in the overview page as well !

Why does the property not work?

I also did not really understand, where to configure, if the detailpage renders with or whitout .html?

Can you help with that - too?

Are you using an Essentials List component in the overview (or a sub class)? I think they allow you to configure a path there as well that may override what is set on the relative content path.

I am using: org.onehippo.cms7.essentials.components.EssentialsListComponent.

@jasper.floor: Your right, in the configuration of the component I found a parameter path with a value.
Changing the value here made everthing working :smiley:

There ist still the *.hmtl question. Any hints?