As I am new to Bloomreach I am following the tutorials, currently I am on this step:
It feels weird to have a tag called 'headContributions which has categories which can indicate to NOT add it to the html after all? Maybe you could call it ‘hst.clientLib’ instead? I also work with Adobe Experience Manager, so to me that feels like a more logical name for a tag which contains CSS and/or JS.
If you opt for something like this, I guess it would be a good idea to support both for a while but only use the new name in tutorials and remove the old one after a while.