Copy pasting a word image freezes the CMS


We are facing a strange problem with Bloomreach 12 when copy pasting an image from a word document into the body of a document in the CMS. Basically the CMS becomes unresponsive and does not allow any operations unless you close the browser tab.

I have looked for some information about this as well as in the logs to see if we can get any clues of what is happening but unfortunately I found nothing.

Is there a way of fixing or at least circumvent this situation?


What exactly do you mean by image? Is it a file (eg, jpeg, png…) a diagram? I’m afraid I personally don’t have access to word so I can’t test it out. Is the behavior browser dependent? What browser(s) have you tried?

It seems to happen at least with .jpg, .jpeg and .png images (I haven’t tried other formats yet) and the browsers I have used are the latest versions of Chrome and Mozilla.

I tried it with open office, on Linux Mint, with FireFox. I had no problems but the image link was a file reference which couldn’t be resolved. Are you using an online document? Check your network tab to see if there is any traffic initiated because of the paste. I don’t think your image is actually copied to the document but a reference to the image. It may be stuck trying to resolve a link it can’t access.

I just tried from a Google docs document using a png in my drive. The image was actually copied into the document as base64 encoded image. From open office and a local file it was “file://” url. SO it may difffer how this is inserted.