Custom E Form for Demo

I am trying to build one demo project which contains banner, documents and Form. I was trying to find any e-form demo example but couldn’t find (some of them I don’t have access to download). Kindly help to share or guide me to create one from demo project .


see Customize E form for demo - #2 by machak

I already have an access. I work for Florida Blue. We had a training few weeks back and now tryin to work on it but not able to get into it. So could you please help me with demo example

Hi Vishesh,
We have it zipped and available at

You would need it mostly for the rendering templates, if you use those, see Install Enterprise Forms HST Components - Bloomreach Experience - Headless Digital Experience Platform

Regards, Jeroen

1 Like

Hello, after using above demo example, I am trying to create one simple Email form page and trying to publish/view it, but not publishing/view it, looks some configuration is missing(below attached screen shot)

Could you please guide on this.

Note- Let me know if there is any video or notes available for reference purpose. So i can fallow same and try to create one new form page with proper configuration.

Thanks in advance.

You need to create a sitemap item so system knows how to find it and how to render it:

If you are already running demo example, you can make a copy of an existing sitemap item (via http://localhost:8080/cms/console/ ),
just change the name and content path, so it points to your eform document.

You can also create a wildcard sitemap item, so it maps any document created:

1 Like

While creating new page - component - Enterprise Form - not getting select option to select pre-defined form (it’s showing just default option).I am trying to add form page that i have created but not able to find way to select it. Below is the screenshot.

Please guide. Thank you in advance.

Hi, this could be a frond-end issue, I’ve seen this before where and hitting F5 would resolve it…
Do you seen any error in the browser console?


Nope it’s still not working :frowning:

Hi, there is no error in browser console. not sure what causing this issues. Tried many way but still no luck. Are we missing any configuration ?

Could you pls guide.

Note- the e-form pages that I have created it’s not showing in exp-mgr sitemap, Do it require there, if yes, do we need to do any configuration.

Hmm I’m experiencing something similar on our public demo at when dropping the Enterprise Form component. It has a JS error “Uncaught SyntaxError: Unexpected token ‘;’” though.

After dropping, selecting a different component and the the Form again does work. Do you see the same?


PS the forms demo has explicit site map items indeed. But that doesn’t relate to the properties not showing.