Error after installing B2C Commerce Accelerator


I have today setup the brXM version 14.2.2. After setting up the basic project configuration as given here Get Started, I followed the steps for Installing Bloomreach B2C Commerce Accelerator given here Install Bloomreach B2C Commerce Accelerator.

After running mvn clean verify the server startup with the command mvn -P gives the following error:

[INFO] [talledLocalContainer] 15:54:44 INFO  Finished index repair in 21 ms
[INFO] [talledLocalContainer] 12.10.2020 15:54:50 ERROR main [RepositoryServlet.init:249] Error while setting up JCR repository: 
[INFO] [talledLocalContainer] javax.jcr.RepositoryException: unchecked exception: java.lang.NoClassDefFoundError: com/fasterxml/jackson/annotation/JsonInclude$Include
[INFO] [talledLocalContainer] 	at org.hippoecm.repository.HippoRepositoryFactory.getHippoRepository( ~[hippo-repository-connector-14.2.2.jar:14.2.2]
[INFO] [talledLocalContainer] 	at org.hippoecm.repository.RepositoryServlet.init( [hippo-repository-servlets-14.2.2.jar:14.2.2]
[INFO] [talledLocalContainer] 	at org.apache.catalina.core.StandardWrapper.initServlet( [catalina.jar:9.0.31]
[INFO] [talledLocalContainer] 	at org.apache.catalina.core.StandardWrapper.loadServlet( [catalina.jar:9.0.31]
[INFO] [talledLocalContainer] 	at org.apache.catalina.core.StandardWrapper.load( [catalina.jar:9.0.31]
[INFO] [talledLocalContainer] 	at org.apache.catalina.core.StandardContext.loadOnStartup( [catalina.jar:9.0.31]
[INFO] [talledLocalContainer] 	at org.apache.catalina.core.StandardContext.startInternal( [catalina.jar:9.0.31]
[INFO] [talledLocalContainer] 	at org.apache.catalina.util.LifecycleBase.start( [catalina.jar:9.0.31]


[INFO] [talledLocalContainer] 	... 55 more
[INFO] [talledLocalContainer] Caused by: java.lang.ClassNotFoundException: com.fasterxml.jackson.annotation.PropertyAccessor
[INFO] [talledLocalContainer] 	at org.apache.catalina.loader.WebappClassLoaderBase.loadClass( ~[catalina.jar:9.0.31]
[INFO] [talledLocalContainer] 	at org.apache.catalina.loader.WebappClassLoaderBase.loadClass( ~[catalina.jar:9.0.31]
[INFO] [talledLocalContainer] 	at java.lang.Class.getDeclaredMethods0(Native Method) ~[?:1.8.0_231]

And few more, I can’t paste all due to limited text allowance.

What am I missing?

I have before used installing starterstoreboot project using Install B2C Commerce Using Boot Project in the past so I know how it should run. Unfortunately the new way of installing B2C Commerce Accelerator is giving me the above error.


Tagging @giacomolm as you have helped me a lot in the past :slight_smile:

Thanks in advance!

Hi @rsingh1

just tried a fresh install and I cannot reproduce this issue. Could you please ensure that the jackson-annotation jar ends up in your cargo (tomcat) shared folder ?

Hi @giacomolm thanks for your reply.

You are right, the jackson-annotation jar is not ending up inside the tomcat folder.

I have retried a couple of times ending up with same problem.


Any help on this one as I am still getting the same error.

comparing the /shared/lib library folder with the file src/main/assembly/shared-lib-component.xml, I see that jackson-annotations and starterstore-api jars are missing from /shared/lib library folder. I am not getting any errror on mvn clean verify

Hi @rsingh1,

it seems not strictly related to the commerce accelerator installation, IMHO.

From my understanding you are testing the installation on a newly created project: more specifically, you’ve created a brand new project based on 14.2.2 [1]

As a next step, I would advice to convert your project to an “enterprise” project, as documented here [2]. Please follow the “Convert through essentials” paragraph.
Once the previous step is over, then you can install the b2c-commerce-accelerator.

Please execute those steps (again) and see what happens.

If you have some dependency issues, perhaps you will notice them while “converting” the project to enterprise, hence before installing the


Hi @giacomolm

It worked now!!

Although I did follow to convert my project to an enterprise project before installing B2C Commerce Accelerator. The only difference in my steps was that before I was converting my project to “enterprise” through essentials alongwith installing some other components like Banners, Videos etc. before installing B2C Accelerator.

This time I only installed “Convert to Enterprise Project” and now it seems to be working.

I can’t understand the reason for installing some components before installing B2C accelerator which caused jackson-annotations jar not being copind in shared lib?

Thanks a lot for your help though!