Error run or build docker-image

I made a fresh download of brxM 14.4.0.
When I run mvn -P I get the following error:

    Failed to execute goal io.fabric8:docker-maven-plugin:0.35.0:build (Build docker container) on project testproject: Unable to pull 'tomcat:9-jdk8-openjdk-slim' : {"message":"Head https://registry-1.d unauthorized: incorrect username or password"} (Internal Server Error: 500) -> [Help 1]

When I run mvn -P I get the folowing error:

[INFO] --- docker-maven-plugin:0.35.0:remove (Delete docker image) @ testproject ---
[ERROR] DOCKER> Multiple assemblies use the name %s. Please assign each assembly a unique name.

and with version 0.28 of docker-maven-plugin I recive the following error:

[INFO] --- docker-maven-plugin:0.28.0:remove (Delete docker image) @ testproject ---
[ERROR] DOCKER> Cannot create docker access object  [Connect to localhost:2375 
[localhost/, localhost/0:0:0:0:0:0:0:1] failed: Connection refused: connect]

and when I activate the option Expose daemon on tcp://localhost:2375 without TLS in docker desktop setting I get the following error:

[ERROR] Failed to execute goal io.fabric8:docker-maven-plugin:0.28.0:build (Build docker dev container) on project testproject: Unable to pull 'org.lienas/testproject:0.1.0-SNAPSHO
T' from registry 'org.lienas' : {"message":"Get https://org.lienas/v2/: dial tcp: lookup org.lienas on no such host"} (Internal Server Error: 500) -> [Help 1]

Any suggestions ??

I made some further investigations. I ran the target from a Linux machine- there I got the following error:

[ERROR] Failed to execute goal on project testproject: Could not resolve dependencies for project org.lienas:testproject:pom:0.1.0-SNAPSHOT: Failed to collect dependencies at org.lienas:testproject-essent
ials:war:0.1.0-SNAPSHOT: Failed to read artifact descriptor for org.lienas:testproject-essentials:war:0.1.0-SNAPSHOT: Could not transfer artifact org.lienas:testproject-essentials:pom:0.1.0-SNAPSHOT from/
to hippo-maven2-enterprise ( Not authorized -> [Help 1]

Do I need an enterprise license to run brxM in a Docker Container ?

that maven plugin profile never worked for me for some reason…well, never is exaggerated but it was always throwing some errors. I would suggest to follow this recipe:

Thx for your response- I will try this over the weekend and report the result here!

Hi, in your main POM file, you will need to specify this property


This then overides and the default version as there are known issues with it.


Hi J,

it works with version 33- thx.
I tried the newer version 35 - what not worked :frowning:


Awesome glad to help out.