ExtLinkPicker not working in brXM 15.1.0

Hi,

We are in the middle of upgrading our aplication from brXM 14.6.0 to 15.1.0
We found bug with hst.manageContent function (Render a 'Manage Content' Button in the Experience Manager - Bloomreach Experience Manager (PaaS/Self-Hosted) - The Fast and Flexible Headless CMS)
Everything is working fine in version 14.6 but in new version Create new content(Manage Content in a Channel - Bloomreach Experience Manager (PaaS/Self-Hosted) - The Fast and Flexible Headless CMS)
is not working fine. After clicking + button there is displayed Create content panel, but its impossible to pick “Document Location” due to:

TypeError: Cannot create property ‘rootPath’ on string ‘/’
at constructor._firePickEvent (ExtLinkPicker-ver-1658312215604.js:42:17)
at constructor.openPicker (ExtLinkPicker-ver-1658312215604.js:36:6)
at constructor._showPathPicker (channel-editor-bundle-ver-1658312215604.js:2254:52)
at call (message-bus-ver-1658312215600.js:37:20)
at Object.publish (message-bus-ver-1658312215600.js:49:8)
at i.publish (cms.service.js:65:25)
at r._pickItem (picker.service.js:63:21)
at r.pickPath (picker.service.js:35:17)
at o.openPicker (documentLocationField.controller.js:94:24)
at fn (eval at compile (angular.js:16486:14), :4:180)

If we setup rootPath in hst.manageContent we can create document, but only in provided path(can’t change it due to same error). For example: rootPath=“/content/documents/folder”
I was thinking that maybe we have some bad code, but same error happens on clean app with Blog feature installed from essentials which have uses this function to create Blog Posts.

While debugging this error, I noticed that the ExtLinkPicker implementation has changed, is it correct? Maybe there is a documentation error and we need to make changes to the code?

1 Like

@jeroen.hoffman could you look into this?

Hi Andrzej,
I could reproduce this on a 15.1 archetype-based project, using Blog feature.
I’ll inform our Engineers about it, thanks for the report.

Jeroen

FYI this is now product issue https://issues.onehippo.com/browse/CMS-15131, it has our attention.

Thanks, we are waiting for fix :wink: