Page model api throws 500 error

Hi all,

I’m having some trouble with my resourceapi.
I have configured my page model api to the http://localhost:8080/site/resourceapi.
And it worked before, together with my React SPA application. (Could view banners)
But now while editing I get a 500 error on this resourceapi page, even after stashing all my changes with Git, cleaning and verify, and rerunning. But the problem won’t go away.

I’ve also tried to remove things like the preview node from the console, changing the storage location of the repo.path.

Is there logging I can look at to determine what is causing this 500 error?

Thanks in advance.

Hi Yazid,

Could you share your host configuration yaml?

Additionally, you can set the log level to debug in the log4j2 file to get more information as to why the error is occurring. Usually, 500 errors actually do log helpful information even at the info level as they are errors. Perhaps you could share your build/deploy/request logs.

Hi Nicholas,

I already fixed it by removing the git repository locally and retrieving it again.
Something just happened that messed up the project I think.