Scheduler not working

I tried to implement a simple scheduler. Here is my code:

package de.lienas.feeds.api;

import org.onehippo.repository.scheduling.RepositoryJob;
import org.onehippo.repository.scheduling.RepositoryJobExecutionContext;
import org.slf4j.Logger;
import org.slf4j.LoggerFactory;

import javax.jcr.RepositoryException;
import javax.jcr.Session;
import javax.jcr.SimpleCredentials;

 * Imports feeds from {@link de.lienas.feeds.dao.FeedReader}

public class FeedImporter implements RepositoryJob {
    private static final Logger logger = LoggerFactory.getLogger(FeedImporter.class);

    public FeedImporter() {

    public void execute(RepositoryJobExecutionContext repositoryJobExecutionContext) {"Successfully started scheduled job for import of feeds");

        try {
            Session session = repositoryJobExecutionContext.createSession(new SimpleCredentials("admin", "admin".toCharArray()));
  "Successfully connected to Repository :-)");

        } catch (RepositoryException e) {

            logger.error("Could not connect to repository: {}", e.getMessage());


The class is inside a separate modul! I configured the scheduler job manually:

  jcr:primaryType: hipposched:jobgroup
    jcr:primaryType: hipposched:repositoryjob
    hipposched:repositoryJobClass: de.lienas.feeds.api.FeedImporter
      jcr:primaryType: hipposched:triggers
        jcr:primaryType: hipposched:crontrigger
        jcr:uuid: 62d45379-f2b7-44ca-8f72-415b2c22c1ca
        hipposched:cronExpression: 0 0/1 * * * ?
        hipposched:nextFireTime: 2020-03-04T20:32:00+01:00

The nextFireTime get refreshed every minute as exspected. I do not get any log-info. I also tried to call one of the predefined jobs org.hippoecm.repository.logging.EventLogCleanupJob- same result no log entry.

What did I miss?

I would say check your log4j settings. “org.hippoecm.repository” is set to warn for development so you wouldn’t see any info messages. For your own code you need to add loggers.

The problem was,that the package-name for the project is org.lienas.* and in the module I used de.lienas.. For de.lienas. certainly no logger was available.