Showing error in APIs generated by hippo

hi friends getting following error when i click on site/api/documents what would be the problem can you figure it out??

Mahesh, it was early when I saw your message, and then I started getting tickets that talked about the same api end point, and I jumped to a conclusion. The type: “invalid” occurs when nothing is selected in the document. If you associate a document to that specific link, it will resolve as normal.

example after a document is picked.:
“link”: {
“id”: “a2d3ff5b-60a4-4e1d-8e16-14ccc4164100”,
“type”: “local”,
“url”: “http://localhost:8080/site/preview/api/documents/a2d3ff5b-60a4-4e1d-8e16-14ccc4164100
“type”: “hippo:mirror”

Hello mdg thank you for your reply, I attached the version information look into it and respond me soon

hi mdg,

I selected a specific document for each and every link, it was showing APIs fine and working fine earlier but from today its showing invalid in type as shown in image. The data associated with these APIs are disabled from site. I am not getting exact reason why its showing invalid and how to resolve it. If i need to do any console settings please tell me soon it will be helpful

thank you

Mahesh-- I did not do anything special to get the data to appear in /site/api/documents/ I am using the OOTB document selector.

Only thing different on your JSON data is the types under the link attr, example “devepragaticms:newsdocument” vs. hippo:mirror, Are you using the OOTB selector, if so can you share the document.yaml for the above attribute (not the newsdocument but whatever generated your JSON)?

what is OOTB where we can use it?? and where i can see hippo:mirror settings??

OOTB means “Out of the Box”, or the default selector.

hippo:mirror should be in the YAML file of your code base.

ya i am using OOTB document selector

I will see the YAML coding

thank you