13.0.2 Upgrade issues

Hello! I’m currently trying to upgrade our developer edition install from 12.6.3 to 13.0.2 in anticipation of switching to the licensed version.

I’ve followed the upgrade steps listed here and while I’m able to build the project fine, I’m unable to run the project either in a development environment or locally with cargo.

I receive errors that the standard contexts can’t start for both /cms and /site. Depending on how I’m trying to run the project, I get a different class not found error, but both classes are contained in the hst-api dependency.

Environment: “Caused by: java.lang.NoClassDefFoundError: org/hippoecm/hst/core/container/ContainerException”
Cargo: “Caused by: java.lang.NoClassDefFoundError: org/hippoecm/hst/platform/model/HstModelRegistry”

(Note I’d originally seen HstModelRegistry set as missing earlier when I had the CMS context listener instead of the platform context listener used for the CMS web.xml.)

As per the CMS dependency upgrade page, I’ve ensured that hst-api isn’t listed in the CMS pom, and if I run mvn dependency:tree, I see the hst-api jar listed as scope “provided” for cms, site and repo.

I’ve compared this to the 13.0.2 archetype, and see that hst-api is listed with mvn dependency:tree in a lot more places, though since this uses the multi-site mode it can be hard to tell - in my project I don’t see the hst-api dependency listed in the project base, nor in repo-data-application, development or web files like I do for the archetype.

I see that the only place the hst-api dependency is explicitly listed in the archetype is in the shared-lib-component.xml file in src/main/assembly (as listed in https://documentation.bloomreach.com/library/upgrade-12-to-13/steps/cms-dependency-upgrade.html). The same is true for our own install - the dependency isn’t listed explicitly anywhere. I should note that we don’t have a shared-lib-component.xml file - as I understood from the page, this is only necessary if you’re using mvn -Pdist. I tried implementing these same files into my project but didn’t see any change to the cargo errors I’ve described above.

I’m also unsure of the new hosts.yaml layout, but my understanding is that any errors with the new CMS mounts would only result in the channel manager view breaking rather than cargo startup errors.

Would really appreciate any help, if others have experienced anything similar!

Here’s what I’m working from, if it’s helpful:

works for me after removing some invalid yaml files: your hosts file has wrong indenting and also some invalid entries. Brokenlink plugin references also need to be removed (plugin is discontinued)


It might be some wrong dependencies are being pulled in your parent pom

Cheers machak! Indeed, I needed to update the dependencies as you said. Thanks for the additional info - gonna work on getting the hosts file sorted and I’ll take a look at the plugin.