Can't create project from archetype for version 13.0.0


#1

Hi,

I’m trying to create a new project, using the archetype, using the following command:

mvn org.apache.maven.plugins:maven-archetype-plugin:2.4:generate \
-DarchetypeRepository=https://maven.onehippo.com/maven2-enterprise \
-DarchetypeGroupId=org.onehippo.cms7 \
-DarchetypeArtifactId=hippo-project-archetype \
-DarchetypeVersion=13.0.0

However I get presented with the following error:

Downloading from hippo-project-archetype-repo: https://maven.onehippo.com/maven2/org/onehippo/cms7/hippo-project-archetype/13.0.0/hippo-project-archetype-13.0.0.jar
Downloading from central: https://repo.maven.apache.org/maven2/org/onehippo/cms7/hippo-project-archetype/13.0.0/hippo-project-archetype-13.0.0.jar
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time:  1.078 s
[INFO] Finished at: 2019-01-10T09:48:10+01:00
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-archetype-plugin:2.4:generate (default-cli) on project standalone-pom: The desired archetype does not exist (org.onehippo.cms7:hippo-project-archetype:13.0.0) -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException

This might suggest it can’t retrieve the definition from the maven repository, but when I tried the archetype with version 12.6.0 it did work.

Any suggestion as to what I might be doing wrong is welcome, but it appears as if the archetype wasn’t defined properly, perhaps?


#2

Hey Jens,

are you sure you have access to https://maven.onehippo.com/maven2-enterprise ? Since we did not yet publicly announce the 13.0.0, the archetype is not yet deployed to the community mvn repository, so that https://maven.onehippo.com/maven2/org/onehippo/cms7/hippo-project-archetype/13.0.0/hippo-project-archetype-13.0.0.jar can’t be found is correct. However it is present in the enterprise mvn repo at https://maven.onehippo.com/maven2-enterprise/org/onehippo/cms7/hippo-project-archetype/13.0.0/ . Can you validate whether you have really access to that mvn repo?

Regards Ard


#3

or just use one from:


and upgrade to enterprise pom with essentials.


#4

Hi Ard,

Thanks for getting back to me. I found out that my credentials for the enterprise repository were set in my maven settings.xml file with the id hippo-maven2-enterprise and the archetype required an id of hippo-project-archetype-repo. So basically I duplicated my credentials node in the settings.xml and changed the id to hippo-project-archetype-repo and now it works.

Example:

<servers>
    <server>
    	<id>hippo-maven2-enterprise</id>
    	<username>user</username>
    	<password>pass</password>
    </server>
    <server>
    	<id>hippo-project-archetype-repo</id>
    	<username>user</username>
		<password>pass</password>
	</server>
</servers>

Thanks for helping out!

Kind regards,
Jens