Getting started tutorial error

Trying to run the following on my Windows 10 machine with Java 8 installed.

mvn org.apache.maven.plugins:maven-archetype-plugin:2.4:generate -DarchetypeRepository=https://maven.onehippo.com/maven2 -DarchetypeGroupId=org.onehippo.cms7 -DarchetypeArtifactId=hippo-project-archetype -DarchetypeVersion=13.2.0

The error is:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-archetype-plugin:2.4:generate (default-cli) on project tutorial: The desired archetype does not exist (org:hippo-project-archetype:13) -> [Help 1]

I see further up that it’s trying to download a jar:

Downloading from hippo-project-archetype-repo: https://maven.onehippo.com/maven2/org/hippo-project-archetype/13/hippo-project-archetype-13.jar

When I try to browse that URL I get a 404.

Can you have java and maven paths correct

OF701VC0PFHTD82:~ kon9045$ java -version

java version “1.8.0_202”

Java™ SE Runtime Environment (build 1.8.0_202-b08)

Java HotSpot™ 64-Bit Server VM (build 25.202-b08, mixed mode)

OF701VC0PFHTD82:~ yuy9045$ mvn -V

Apache Maven 3.6.1 (d66c9c0b3152b2e69ee9bac180bb8fcc8e6af555; 2019-04-04T12:00:29-07:00)

Maven home: /Users/yuy9045/Documents/Softwares/apache-maven-3.6.1

I can run Java and am able to build other maven projects. So my paths are correct.

Patrick Vecchio

Consultant

Slalom, LLC

it downloaded for me. looks some thing blocking

More over it should look for https://maven.onehippo.com/maven2/org/onehippo/cms7/hippo-project-archetype/13.2.0/hippo-project-archetype-13.2.0.jar in your case it looking for 13 jar

Thanks for checking. Just tried it again and got the same error. I’ll keep trying.

I was able to download and run in Linux.

Oh nice looks some issue with windows machine :+1: