Content Rewriter not working in Brxm 15.1.4

I am trying to implement a global content rewriter as documented here: HST Rewriting rich text field runtime
I am trying this in Bloomreach v15.1.4

I have followed the steps, i.e:

  1. Edit site/webapp/src/main/webapp/WEB-INF/ to add the property:
# Override the default HST ContentRewriter
default.hst.contentrewriter.class = com.example.CustomInternalLinksContentRewriter
  1. I have also implemented the CustomInternalLinksContentRewriter this way:
public class CustomInternalLinksContentRewriter extends SimpleContentRewriter {
    public String rewrite(final String html, final Node node, final HstRequestContext requestContext, final Mount targetMount) {

This is not working, I have put breakpoints in this class and additional logging but it seems it’s never called. I have also added break points in the SimpleContentRewriter class and it seems the rewrite methods in that class as well are not called.

Is there something that I am missing?

Could you try setting the property in the in the CMS webapp? It is processed in hst-core.jar which is in both webapps, not sure if the documentation is outdated since large parts of HST moved to the CMS.

I have tried setting the property in the CMS webapp yes, and still not working unfortunately

I have tried this in an archetype project with the essentials news feature installed. in the site app. It works for me. Are you seeing any errors in your logs?

No, I am not seeing any errors in the logs. It seems like the content rewrite module is not being used at all. I will review my configuration maybe there is some config that’s causing this issue