URL Rewriter content folders and options not showing

I have installed URL Rewriter from essentials. It works locally. I have deployed it to my QA environment. I see URL Rewriter in the dropdown list in content on QA, but when I select it, I see no button to add root folder on this environment. Can someone please point me at what I might be doing wrong?

Hello @samwest88, which version of brXM are you using? If on v14 I am guessing that your user has the userrole xm.urlrewriter.admin assigned to him already, right?

Could you make sure that your configuration looks similar to the screenshots below? (these are v14 again)

Otherwise, start an archetype of your version and compare the configuration with your QA environment.

Kind regards,

Hi Lef,

Thanks for your suggestions. I am on v14.1. Permission required for that version is xm.repository.admin, which was correctly set. I have tried relaxing the user permissions on my QA environment to be xm.content.user, but unfortunately this has had no effect. I have compared the configuration pages that you sent in the screenshots on my local and QA environments and cannot see any differences there (aside from now the lowered permission level). On my QA environment, my CMS URL is accessible through a different url (https://cms.nhbcqa…) to the front end (https://nhbcqa…) - could this be having an effect?

if you have no root folder, it might not been bootstrapped (content, cnd )

Hi machak,

Locally (working) I have a content->urlrewriter node in the cms/console. But on QA (not working) I do not have this urlrewriter node on QA. Is this not because I have created content locally, which I have not been able to do on QA yet though? Or is this an indication that I need to do the bootstrapping that you have mentioned? (not sure how to do that?)

Just for anyone coming accross this, here’s how I fixed it. machak’s hit pointed me in the right direction. I needed a urlrewrite node under content on QA (assume something wasn’t committed auto-export wise properly for this to happen). I was able to export this as yaml locally and import it into the same place on my QA environment. I then was able to both add root folders and create the rewrite “content” underneath this folder.