Not able to publish and discard in channel editor

Hello everybody,

Since a week or so the “discard” and “publish” button in the Channel Manager of our production environment do not seem to work properly anymore. This is the reproduction path:

  1. I edit something in the Channel editor and try to discard it by clicking on the “discard” button.
  2. A prompt shows up asking me if I’m sure I want to discard my changes and I click “yes”

Normally this should discard my changes, however nothing seems to happen… Has anyone had this problem before? I can’t find anything in the logs and I am unable to reproduce this locally. I thought it could be related to, since we’re still on version 12, however I do not see any javascript error logs which I think are related to this issue.

Please let me know if you’ve had anything similar to it or if you have any idea on how I should approach this problem :slight_smile:

Have you tried throwing away the preview node in the console? and then accessing the channelmanager again?

I tried, but the problem is still there unfortunately :frowning:
I have tried to do a redeploy, which also did not work. My last option now is to reindex, which I will be doing today… Hopefully this will work… Any tips are still welcome!