Not able to set jsp in property hst:renderpath for template

#1

Hello,
I am trying to use JSP instead of .ftl files. I have added one template and trying to set my jsp file path (pdp.jsp). But I am getting jsp file not found error though jsp file exist in the path. if I change it to .ftl (pdp.ftl) then it works. I want to use jsp tags so trying to add files. Here is the screenshot from cms/console

Thanks

Display Taxonomy on page
#2

You cannot use JSP files as webfiles…those needs to be pre-compiled (so, you need to package them within war. file and no hot-reloading is possible by utilizing webfiles feature).
Either stick with FTL or you could try one of these:

https://bloomreach-forge.github.io/templating-support/

1 Like
#3

Or you should put your .jsp files in the standard webapp resource locations, not in webfiles–which is a brXM specific solution, such as:

  • /WEB-INF/jsp/gogreen/pdp.jsp (with setting hst:renderpath to jsp/gogreen/pdp.jsp)
  • or /myjspexamplefolder/gogreen/pdp.jsp (with setting hst:renderpath to /myjspexamplefolder/gogreen/pdp.jsp.

If the hst:renderpath doesn’t start with /, HST finds it under /WEB-INF. Otherwise, just find it from the application context path directly.

Woonsan

1 Like
#4

Thank you woonsan, for reply. This helped me :+1: