'Tools' option not showing under 'Page' option for a channel

Hi Team,

I am trying to create Custom ui extension for a page. but not able to see ‘Tools’ option under ‘Page’ option as mentioned in below documentation.

I have added “frontend:extensionPoint” property to “channel.page.tools”
Am I missing any configuration ?


Hi Yod,

Please add frontend:displayName , frontend:extensionPoint and frontend:url to create custom UI extension for a page. Here is the sample:
jcr:primaryType: frontend:uiExtension
frontend:displayName: Show JSON
frontend:extensionPoint: channel.page.tools
frontend:url: http://localhost:9000

Refer to the documentation here for further details.

Hi Hema,

Thanks alot for quick reponse. I have all the configurations as mentioned above and UI application also created following the documentation you have linked.

But I don’t see tools option under page in Experience Manager.
I have attached Screen shots below for reference.

So are the configurations shown in the image enough to get the ‘Tools’ option under ‘Page’?

Thank you,

Hi Yod,

The configuration shown above is enough to get ‘Tools’ option under Page. A page tool must be configured with a node of type frontend:uiExtension as child node of the node at the path /hippo:configuration/hippo:frontend/cms/ui-extensions.
In the above example I have added ‘showJson’ as a child node. After you add the node and set the properties along with values, make sure you write the changes to the repository. If you are still facing the issue, let me know.
More details : Configure a Page Tool - Bloomreach Experience Manager (PaaS/Self-Hosted) - The Fast and Flexible Headless CMS