QA Environment Is not adding to New Document.. list


I have created a new document type and committed it.

This document should then immediately appear in the dropdown list for “Add new document…” when you click on a folder under Content → Documents, but currently it is not.

Any pointers as to why this might happen? I can see it in the console at hippo:namespaces/projectname/documentTypeNameHere. Is it supposed to be somewhere else too?

Locally this is working, but not on my QA environment.

I am using bloomreach version 14.1.0


Hi Sam,

Make sure you are not generating document types directly in the QA environment. They should be created locally and then pushed up to the QA environment as part of the distribution. Please also make sure you generate the Java Beans for the new doc type.

Hi we are having the same issue here. We have added the document in dev, and the relevant java bean as well, but its not showing up in our QA environment. The document type has been created, but you cannot create any content from it…?

Is there a query somewhere that needs to be updated to allow it to show?

This is version 14.5 now


have you created Template Query?

Yup its there, I can see it in the console, however I cannot select it if I want to constrain the content folder…not that we do anyway.

To prove the theory I created a quick test document in QA and its visible straight away in the list of documents… so something is not joining up.

what if you edit specific document type and commit your changes?
Although, I would expect query to show up at least…

Already tried that and no joy either. Really Really weird…
it all works locally fine, even from a vanilla implementation… its like something is not joined up, but not sure what…

solved it by overwriting QA Database with one from UAT and redeployed the code and it all worked…